 //head//

Countdown clock

//strap//

This month, Tom Knowles uses Fireworks and Flash to build a graphical countdown clock.
//level//

Intermediate

//time//

90 minutes

//next month//
Next month, we’ll use Freehand MX and Flash MX 2004 to create a classic sliding puzzle game.

//on the .net cd//
On the CD you will find a 30-day trial version of Studio MX 2004, Macromedia’s latest suite of authoring tools, and all the files from this walkthrough.

//intro copy// 270

In the current climate of usability, accessibility, code standards and other rather po-faced aspects of web design, it’s quite easy to negate the needs for experimentation and daring to be different. Yet some of the best, most widely used web site concepts were born out of going down blind alleys in the first place. And while the current focus on usability et al has to be a good thing, there are still plenty of opportunities to try and stretch the boundaries a little. Obviously, this is dependent on your target audience, and what it is you’re trying to achieve. There’s not much point in trying some recklessly abstruse Flash techniques when you’re putting together a site for an old people’s home, for example. 

But what if you’re actually asked to do something a little bit different? What if you’re not really being asked to build a web ‘site’ per se, but something more temporary, more akin to a flyer or an advert? In this sort of case, it pays to think outside of the usual parameters. Notable developers who have used these sorts of projects to push the industry’s expectations of Flash include Joshua Davis (http://www.joshuadavis.com), Branden Hall (http://www.waxpraxis.org/) and Yugo Nakamura (http://www.yugop.com). 

This month, we’re going to pretend that we’ve been given the task of developing an interesting ‘holding page’ for a forthcoming city bar. Rather than simply go down the usual ‘under construction’ style HTML layout, we’re going to create a dynamic Flash clock which counts down to the opening date, and which uses an XML-driven selection of city images in a random and eye-catching fashion.

//walkthrough // 15*55

1. Our countdown clock is going to feature a border of randomly cycled image thumbnails. Rather than manually resize each image down to the correct size, we’re going to use Fireworks MX 2004’s batch process function. Open Fireworks, and choose File -> Batch Process. Once you’ve done this, you’ll be presented with the familiar explorer box.

2. Browse to the folder where you’re keeping all the full-size images, and select all the photos you need. For this project, we’re going to need 20 images. Once you’ve got your selection, click ‘Add’, followed by ‘Next’. You’ll now be given a number of processing options. Choose ‘Scale’ and hit the ‘Add’ button.

3. In the drop-down at the bottom of the window, pick ‘Scale to Size’, and set the size as 70x70 pixels. Now return to the batch options section and choose ‘Export’. This time, pick ‘JPEG – Smaller File’ from the drop-down. You can edit the precise export settings if you wish. When you’re done, click ‘Next’.

4. In the next screen, pick a new folder for your soon-to-be-resized images. We’ve called our folder ‘thumbs’. Now, simply hit ‘Batch’ and sit back and relax. Fireworks will trawl through the original list of images, open each one and resize to your specifications, before exporting it to the new folder. Cool huh?

5. That’s all we need to do in Fireworks, so now let’s open Flash MX 2004, and create a new file. Save the file as ‘pictoclock.fla’, and then choose File -> Publish Settings, and hit the ‘Flash’ tab. Set the ActionScript version to ActionScript 1.0, and check the ‘Protect from import’ and ‘Compress movie’ boxes. 

6. In the document properties panel, set the stage dimensions to 700x500 pixels, and the frame rate to 80fps. The high frame rate ensures that we can evaluate the time quicker than the ‘real time’ system clock. The document size is reasonably unimportant, since we won’t be scaling the movie, but we will use the values in our code.

7. On the main timeline, rename the first layer to ‘includes’. In the Actions panel (Window -> Actions), type the above code. These ‘include’ statements refer to several external ActionScript files, which contain a number of functions and prototype methods. The ‘easing_equations.as’ file contains Robert Penner’s easing equations (also available from http://www.robertpenner.com/).

8. Next, create another layer beneath ‘includes’, and call it ‘functions’. Leave this layer blank for now – we’ll return to it later when we write our main ActionScript code. Underneath it, add another layer called ‘actions’. This layer is where we’ll put a few brief AS statements which deal with the initialisation of the overall movie.

9. Type out the above code in the Actions panel. The ‘stop();’ line simply halts the movie’s playhead, preventing looping. The next two lines make use of the Stage object – we remove the user’s right click options, and ‘noScale’ prevents the movie from being scaled or distorted. This is important since we’ll be taking up 100% of the browser window.

10. The three global variables, ‘_global.speed’, ‘_global.gap’ and ‘_global.sideNum’ refer to the overall fade transition speed, the gap between each thumbnail and the number of images on each side of the border. By using the ‘_global’ prefix, we can access these variables from anywhere in the movie. Finally, we call the ‘loadSequence’ function, which manages the overall data load.

11. Now create a new layer called ‘images’, and choose Insert -> New Symbol -> MovieClip, giving it the name ‘holder’. This is essentially just a blank MovieClip, so all we need to do is drag it onto the stage, and give it the instance name ‘holder’. You don’t have to worry about its position for the moment.

12. On yet another new layer (it makes sense to keep everything on separate layers for ease of editing and organisation), create a new text field. In the properties panel, set it to ‘dynamic text’, and give it the instance name of ‘phrase’. Centre-align it, and don’t forget to embed the font in the character options box.

13. Select the ‘phrase’ textfield, and choose Modify -> Convert to Symbol -> MovieClip. Give this new symbol the name and instance name ‘loading’, and on the main stage, use the align panel to centre it both vertically and horizontally. Unsurprisingly, we’re going to use this MovieClip to display the load progress of the movie, the XML feed and the thumbnail images.

14. Create another new text field (this time with the instance name ‘timefield’) on a new layer, and place it inside a MovieClip with the instance name ‘timeholder’. Make the font size around 40.  Again, on the main stage, centre the clip horizontally and vertically. Finally, set both the ‘timeholder’ and the ‘loading’ MovieClips’ _alpha values to 0.

15. That’s all the pointing and clicking we really need to do. The rest of the countdown clock’s functionality will be produced purely by the ActionScript code on the next couple of pages. When you’ve entered all of the following code, simply choose File -> Publish Preview -> Flash to test the final movie.

//top tip 1//

Macromedia is apparently working flat out to improve performance in the next version of the Flash player, but for now at least, take care not to over-saturate your work with complex animations and heavy graphics. It can cause performance and playback problems, especially when combined with frequent, fast-moving loops such as those on clocks and games. 

//top tip 2//

Fireworks’ batch processing can save a lot of time and effort, but when it comes to real, in-depth control over such processes, you can’t beat the latest version of Photoshop: Photoshop CS. It includes the facility to record any sequence of commands, save them as a script and then apply that script whenever you wish.

//annotated code description //

The init(); initialization function, and the loadSequence() function.

//annotated code intro// 150

Whenever you build anything reasonably complex, the structure of your code is just as important as the structure of your .FLA file. By structure, we mean the breakdown of your script into functions, and the logic of its architecture. Basically, if you’ve got one function which is 100 lines long, you need to think about restructuring it. The reason for this is essentially ease of debugging. By breaking your code down  into the smallest chunks possible, you not only make it easier to understand, but you also make it quicker to search for bugs, because you’re able to narrow down the areas where something might be going wrong.

A classic structure for any application is to have an initializing function which ‘kick starts’ proceedings, and then lets the rest of the application get on with its various jobs. In the following code, we cover this init(); function in addition to the loading script.

//actionscript code part 1// Comments for each chunk below in [ ]

1. function init() {

2.
_global.countdownYear = new Date(2005, 1, 2, 0, 0, 0, 0);

3.
today = new Date();

4.
var millidif = countdownYear.valueOf()-today.valueOf();

5.
days = Math.floor(millidif/86400000);

6.
millidif -= (days*86400000);

7.
hours = Math.floor(millidif/(86400000/24));

8.
millidif -= (hours*(86400000/24));

9.
minutes = Math.floor(millidif/(86400000/24/60));

10.
millidif -= (minutes*(86400000/24/60));

11.
seconds = Math.floor(millidif/(86400000/24/60/60));

12.
millidif -= (seconds*(86400000/24/60/60));

13.
hunseconds = Math.floor(millidif/(86400000/24/60/60/100));
var start = getTimer();

[The very first thing we do in our init() function is to declare the date we’re actually counting down to. We do this by creating a new Date object (countdownYear), and stuffing it with the date we want. Note that the way we actually provide data for the Date object is a little strange, what with Flash treating the first month of the year as 0 rather than 1.

Once we’ve done that, we work out exactly how much time there is between now and then by using a Date object that corresponds to the current day.]
14.
daysleft = simpleFormat(_root.days);

15.
hoursleft = simpleFormat(_root.hours);

16.
minutesleft = simpleFormat(_root.minutes);

17.
secondsleft = simpleFormat(_root.seconds);

18. hunsecondsleft = simpleFormat(_root.hunseconds);

[Since we’re trying to display the time left in the form of a digital clock readout, we need to do some crafty formatting of the numbers before we display them. To do this, we use a custom function (in the ‘as’ folder) which formats the numbers to display as double-digits. ) ]
19.
_root.onEnterFrame = function() {

20.

elapsed = getTimer() - start;

21.

if (elapsed < 1000) {

22.


continue

23.

} 

24.

else {

25.


start = getTimer();

26.


timeholder.fade(100,speed*3);

27. hunsecondsleft -= 100;

[The meat of the clock itself is this onEnterFrame statement. It runs at the frame rate of the movie, and each time it checks the elapsed time (with the getTimer() method) to see what unit of time has passed. If less than a second has passed, we skip the rest of the function. If not, we further analyze the current time. ]
28.


if(hunsecondsleft < 0) {

29.



updateClock();

30.



hunsecondsleft += 100; secondsleft -= 1;

31.


}

32.


if(secondsleft < 0) {

33.



secondsleft += 60; minutesleft -= 1;

34.


}

35.


if(minutesleft < 0) {

36.



minutesleft += 60; hoursleft -= 1;

37.


}

38.


if(hoursleft < 0) {

39.



hoursleft += 24; daysleft -= 1;

40.


}

41.


timeholder.timefield.text = simpleFormat(daysleft) + ":" + simpleFormat(hoursleft) + ":" + simpleFormat(minutesleft) + ":" + simpleFormat(secondsleft);

42.


updateAfterEvent();

43.

}

44.
}

45.
holder.fade(100,speed*3);

46. }

[We break down the elapsed time into hundredths of a second, seconds, minutes and hours.  After doing that, we can then see which values need to change. Eg, If the minutes left are zero, we reset them to 60 and decrement the hours left. If the hours left are zero, we decrement the days left and reset the hours back to 24.]
47. function loadSequence(){

48.
loading._alpha = 100;

49.
loading.phrase.text = "LOADING SYSTEM";

50.
_root.onEnterFrame = function() {

51.

if( _root.getBytesLoaded() == _root.getBytesTotal()) {

52.


loading.phrase.text = "LOADING DATA";

53.


_global.thumbXML = new XML();

54.


thumbXML.ignoreWhite = true;

55.


thumbXML.onLoad = function() {

56.



loading.phrase.text = "LOADING IMAGES";

57.



processXML();

58.


};

59.


var xmlpath = "xml/thumbs.xml";

60.


thumbXML.load(xmlpath);

61.


delete _root.onEnterFrame;

62. }}}

[ The loadSequence function first loads the site itself, using the usual getBytesLoaded/getBytesTotal routine. Once the site is loaded, we then create an XML object (thumbXML), and load our XML file into it. Notice how we provide information to the user throughout,t via the loading text field. When the XML feed is fully loaded, we call the processXML function. ]
//annotated code description 2 // 20

The updateClock() function, the processXML() function and the arrangeImages() function.

//annotated code intro 2// 150

The backbone of the countdown clock is the array of thumbnail images it displays. As with any Flash application worth its salt, our clock fetches its images via an XML file (included on the CD), using the classic For loop to iterate over the structure and stuff the images into a global array. To actually load the images themselves, we use dynamically created instances of the MovieClipLoader class.

Once we’ve got our images, we use a general function called ‘arrangeImages’, which places the images (in random order) in a square layout.  What’s useful about this is that we can use ‘arrangeImages’ whenever we like, whether it’s every second, every minute, or whenever the user clicks their mouse. By encapsulating the arrangement functionality within a separate function, we’ve instantly allowed ourselves flexibility that we wouldn’t have had if we’d kept all of the code in one large chunk.

//actionscript code part 2// Comments for each chunk below in [ ]

1. function updateClock(){

2.
imgArray.mix(); arrangeImages();

3. }

[This function, updateClock, is called every real second. Notice how it doesn’t do an awful lot, apart than calling other functions. You may notice, however, that it calls a method on the imgArray called ‘mix’. This is actually a prototype method, declared in one of our external ActionScript files. A reasonably simple but very useful method, it randomly jumbles the order of a given array.

With the imgArray jumbled, we can then call the arrangeImages function, which loops through it, placing the image.  ]
4. function processXML() {

5.
var thumbs = thumbXML.firstChild.childNodes;

6.
_global.imgArray = new Array();

7.
_global.loadedThumbs = 0;

8. for(var i=0; i<thumbs.length; i++) {

[The processXML function takes the thumbXML data structure, and parses it, pulling out the thumbnail image paths and stuffing duplicated MovieClips into the imgArray. Notice how we use child/parent syntax when dealing with XML documents. ]
9.

holder.createEmptyMovieClip("img"+i,i);

10.

var temp = eval("holder.img"+i);

11.

imgArray.push(temp);

12.

var imgloc = "thumbs/" + thumbs[i].attributes.path;

13.

holder.createEmptyMovieClip("loader"+i,2000+i);

14. holder._alpha = 0 ;

[The duplicateMovieClip statement itself. We use the eval() statement to create a concise, temporary reference to the current clip. This is a more efficient way of handling dynamically created MovieClips, because we don’t have keep using the same complex reference syntax, and hence leaving ourselves open to typos. ]
15.

var tempLoader = eval("holder.loader"+i);

16.

tempLoader.mclListener = new Object();

17.

tempLoader.mclListener.onLoadInit = function(target_mc) {

18.


loadedThumbs++;

19.


if(loadedThumbs == thumbs.length) {

20.



loading.phrase.text = "";

21.



arrangeImages();

22.



holder.center();

23.



init();

24.



arrangeNav();

25.


}

26. };

[To use the MovieClipLoader class properly, you need to pair it with a listener object which listens to the events it broadcasts, and acts accordingly. One of the most important events is ‘onLoadInit’, which is fired when the movie is loaded and initialized. It’s important to distinguish between this and onLoad – which is fired before the initialization, meaning that you can’t immediately access the movie’s properties.]
27.

tempLoader.image_mcl = new MovieClipLoader();

28.

tempLoader.image_mcl.addListener(tempLoader.mclListener);

29.

tempLoader.image_mcl.loadClip(imgloc, temp);

30.
}

31. }

32. function arrangeImages() {

33.
var xval = 0; var yval = 0;

34.
for(var i=0; i<imgArray.length; i++) {

35.

var temp = imgArray[i];

36. temp._x = xval; temp._y = yval;

[The beginning of the arrangeImages function creates a couple of variables (xval and yval), a For loop, and a reference to the current element in the imgArray. The element represents an image thumbnail clip, and we set its coordinates to the values of our xval and yval variables.]
37.

if(i>4 && i< 10) {

38.


if(i == (sideNum -1)) {

39.



_global.toprightX = temp._x;

40.


} yval += (temp._height + gap);

41.

}

42.

else if(i> 9 && i< 15) {

43.


if(i == ((sideNum*2)-2)) {

44.



_global.botrightY = temp._y;

45.


} xval -= (temp._width + gap);

46.

}

47.

else if(i>14) {

48.


if(i == (sideNum - 3)) {

49.



_global.botleftY = temp._y;

50.


} yval -= (temp._height + gap);

51.

}

52.

else {

53.


xval += (temp._width + gap);

54.

}

55.
}

56. }

[The last part of this function is the trickiest, because in it we need to look at the current MovieClip’s position in the imgArray and decide where in the arrangement it should sit. There four sides to the square, and hence four ‘zones’ in which the clips can be, and so it’s case of establishing the point at which we need to move to a different zone, and altering the coordinate incrementation to suit. ]
